There are three physical connections in the example topology for Ethernet Switch1.

1. Fa0/4 to IP Phone extension 2001
2. Fa0/5 to Ethernet Switch 2
3. Fa0/24 to Router 1 port Fa0/0

VLAN 100 - VOICE
VLAN 10 - PC


These steps are to set up QoS on the Catalyst 3550 and create the Voice VLAN.

Switch# configure terminal
Switch1(config)# mls qos !sets up QOS on the switch globally
Switch1(config)# vlan 100 !create the voice VLAN
Switch1(config-vlan)# name VoiceVLAN !Give it a name
Switch1(config-vlan)# exit
TEXT


The mls qos trust dscp pass-through cos interface command allows the DSCP value and 802.1p value to remain unchanged.

Interface fa0/4 is connected to a 5300 or 6900 Series IP Phone that is capable of sending VLAN tagged Ethernet frames. When learning the voice VLAN via CDP (as configured) an 802.1p value of 5 is initially assumed.


In this example VLANs are being assigned to the IP phones using CDP. Configurations for each switch interface below:

Switch1(config)# interface fa0/4 !the connection to the ext 2001
Switch1(config-if)# description "Connection to Ext 2001"
Switch1(config-if)# switchport mode access !port defaults to standard Ethernet frame
Switch1(config-if)# switchport mode access vlan 10 !port vlan for PC
Switch1(config-if)# switchport voice vlan 100 !allows the IP set to learn the VLAN via CDP
Switch1(config-if)# mls qos trust dscp pass-through cos !required to allow DSCP & 802.1p through
Switch1(config-if)# priority-queue out !makes queue 4 a strict priority queue
Switch1(config-if)# spanning-tree portfast !bypasses the spanning the startup procedure
Switch1(config-if)# spanning-tree bpduguard enable !stops spanning tree bpdu messages from being allowed inbound
Switch1(config-if)# exit
Switch1(config)# interface fa0/5 !the VLAN trunk connection to Switch 2
Switch1(config-if)# description "Connection to Switch2"
Switch1(config-if)# switchport trunk encapsulation dot1q !Forces 802.1Q frame
Switch1(config-if)# switchport mode trunk !sends VLAN information across the link
TEXT